Index

Full Version: Locale issue!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
From yakuake
Code:
locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=ru_EE.ISO-8859-1
LANGUAGE=ru:en
LC_CTYPE="ru_EE.ISO-8859-1"
LC_NUMERIC=et_EE.UTF-8
LC_TIME=et_EE.UTF-8
LC_COLLATE="ru_EE.ISO-8859-1"
LC_MONETARY=et_EE.UTF-8
LC_MESSAGES="ru_EE.ISO-8859-1"
LC_PAPER=et_EE.UTF-8
LC_NAME=et_EE.UTF-8
LC_ADDRESS=et_EE.UTF-8
LC_TELEPHONE=et_EE.UTF-8
LC_MEASUREMENT=et_EE.UTF-8
LC_IDENTIFICATION=et_EE.UTF-8
LC_ALL=
From terminal (not X)
Code:
LANG=ru_RU.UTF-8
LANGUAGE=ru_RU:ru:en_US:en
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC=et_EE.UTF-8
LC_TIME=et_EE.UTF-8
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY=et_EE.UTF-8
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER=et_EE.UTF-8
LC_NAME=et_EE.UTF-8
LC_ADDRESS=et_EE.UTF-8
LC_TELEPHONE=et_EE.UTF-8
LC_MEASUREMENT=et_EE.UTF-8
LC_IDENTIFICATION=et_EE.UTF-8
LC_ALL=
From KDE I have no support for RU letters. Seems like KDE too smart override system setup on wrong values.
In first case why I tried change locale. I have an issue with git.
Code:
git fetch
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_PAPER = "et_EE.UTF-8",
        LC_ADDRESS = "et_EE.UTF-8",
        LC_MONETARY = "et_EE.UTF-8",
        LC_NUMERIC = "et_EE.UTF-8",
        LC_TELEPHONE = "et_EE.UTF-8",
        LC_IDENTIFICATION = "et_EE.UTF-8",
        LC_MEASUREMENT = "et_EE.UTF-8",
        LC_TIME = "et_EE.UTF-8",
        LC_NAME = "et_EE.UTF-8",
        LANG = "ru_EE.ISO-8859-1"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

Curios that the same dir from opensuse 13.1 git have no warning. Seems like perl bug? In both systems git 1.8.
This locale setting have broke half my system. Undecided. Any suggestions? Standart locale-gen have no effect.

I think I've found solution
1) nano ~/.kde/env/setlocale.sh for fixing locale var in KDE
2) Don’t send the environment locales from your locale machine to the remote machine. I took this way by just commenting out the line SendEnv LANG LC_* in /etc/ssh/ssh_config as I don’t see any reason to set it on the remote system. This will fix git fetch, but other hand it may be source of issues then you are login by ssh?